Jump to content

Photo

My usb ports are fried.


  • Please log in to reply
3 replies to this topic

#1 (V) (`m`) (V) ︵ ┻━┻

(V) (`m`) (V) ︵ ┻━┻

    Forever in debt to your priceless advice.

  • Members
  • 10,996 posts
  • LocationThey're coming to take me away..

Posted 03 September 2012 - 06:00 PM

I just installed a new cpu and motherboard and since, my Anansi keyboard hasn't installed no matter what I do.

And now,I just went to plugin my sons and his won't work at all.

I checked and it seems to be the left port is unresponsive.


Then I tried the lower back slots and neither of those work either.

And ontop of that, while I had mine aside, they knocked it into the metal beam of my desk and cracked my spacebar in two rendering it useless now.. SO, needless to say that this is really aggravating me,and I'd like to remedy it as quick as possible before any of my other computer parts are rendered unuseable.


Halp,please.

ΝΙΨΟΝ ΑΝΟΜΗΜΑΤΑ ΜΗ ΜΟΝΑΝ ΟΨΙΝ

obazNZl.gif


#2 SpleenBeGone

SpleenBeGone

    Deer Leader of the Goriest Revolution

  • Administrators
  • 14,771 posts
  • LocationHouston

Posted 03 September 2012 - 06:47 PM

Did you install the USB drivers off the disk by any chance?
nmjUGDL.jpg

#3 (V) (`m`) (V) ︵ ┻━┻

(V) (`m`) (V) ︵ ┻━┻

    Forever in debt to your priceless advice.

  • Members
  • 10,996 posts
  • LocationThey're coming to take me away..

Posted 03 September 2012 - 08:02 PM

I wound up getting my front two and bottom two working by resetting the power supply. The middle two still aren't reading, I'll have to try to figure those out another time.

ΝΙΨΟΝ ΑΝΟΜΗΜΑΤΑ ΜΗ ΜΟΝΑΝ ΟΨΙΝ

obazNZl.gif


#4 Jaz

Jaz

    Purify...

  • Members
  • 6,476 posts

Posted 04 September 2012 - 09:26 AM

I wound up getting my front two and bottom two working by resetting the power supply. The middle two still aren't reading, I'll have to try to figure those out another time.


I'm not really useful for hardware, but it sounds like your power supply isn't providing the right voltage

how old is it? is it plugged into a surge protector?